目录

注意事项

当你选择导入Altium Designer时,请务必确认导入的文件内容。

1、目前导入功能属于beta版,导入后请仔细检查!立创EDA并不能确保导入后 100% 匹配!

2、某些细节可能不支持,如设计规则,内电层。

3、内电层导入后需要仔细检查导线,内电层无法保持原有的网络,必须重新设置!

立创EDA目前支持导入的电路设计文件有:

  • Altium Designer/Protel DXP ASCII格式的原理图/PCB
  • Eagle 原理图/PCB/库文件
  • KiCAD 原理图/PCB/库文件

导入步骤

你可以在 文件 > 打开 打开导入对话框。

image-20200709211604473

1、选择 Altium 文件,必须是以ASCII格式另存为的原理图文件和PCB文件。具体操作请看下面教程。

2、根据自己的需要选择导入文件还是提取库。

3、如果同一个工程的原理图和PCB都需要导入,请先导入 PCB 并选择提取封装,再导入PCB和原理图,导入原理图时会自动根据前面提取的封装标题进行关联。有些封装标题因为字符编码的原因无法识别会被转为下划线。

4、如果导入后,从原理图更新到PCB元件没有对应,则可以在:设计菜单 - 重置元件唯一ID,进行元件ID重置,原理图和PCB都需要。此时两边的元件对应关系修正完成。
picture 5

导入Altium Designer原理图文件,PCB文件效果已经非常出色,如下图:

生成ASCII文件格式

Altium另存为ASCII格式:

  • 使用Altium Designer打开原理图/PCB文件(如果没有安装Altium Designer需要自行安装)
  • 打开“文件”菜单
  • 选择“另存为”
  • 文档类型下拉选择ASCII格式: PCB ASCII File(*.PcbDoc) 或 Advanced Schematic ascii(*.SchDoc)
  • 保存。

如果是Protel 99se的文件,请先在Altium Designer打开再根据上面的方式保存,再导入。

导入Alitum库文件

由于Altium Designer原理图库文件,封装库文件并不支持保存为 ASCII格式,所以立创EDA不支持直接导入Altium Designer的库文件。

你可以将需要的导入的库文件全部放在原理图或PCB中,再将原理图和PCB另存为ASCII格式,再导入时选择“提取库文件”即可将库文件全部提取。提取后可以直接放置在相应的画布上,也可以直接添加到个人库中。

picture 2

批量转换ASCII文件

如何批量导入 Altium Designer 已有的原理图和PCB和库文件:

1、下载网友 CZJ 分享的一个 Altium 脚本。http://club.szlcsc.com/article/details_54184_1.html

2、根据脚本的教程提取当前安装好的库文件到原理图或者 PCB.

3、把生成的原理图或 PCB 文件压缩到 zip 压缩包后导入,并提取库。优先提取封装库后再提取符号库。

4、导入后在“左侧元件库 - 符号/封装 - 工作区”处找到提取的库。

常见问题

1、导入AD原理图出现中文乱码

在 AD17 以下的版本,另存为的 ASCII 文件编码可能是 GBK2312,需要把 ASCII 文件的编码由 GBK2312 转为 UTF-8。可以使用文本编辑器另存为 UTF-8 编码的文件。

方法:

  • 1、用 AD17 另存为 ASCII 文件,其默认是 UTF-8 编码

  • 2、或者用系统的记事本打开 ASCII 文件,另存为时选择 UTF-8 编码。其他文本编辑器也有相应的编码转换功能。
    picture 1

2、导入AD文件后存在导线和器件引脚没有对齐格点,或者引脚偏了

  • 先在 Altium Designer 设置原理图的单位为英制mil,在:查看菜单 - 切换单位

图 7

  • 然后画布右键菜单或系统设置:选项 - 网格 - 设置显示网格,电气网格,吸附网格为 100mil,切换网格为 100mil

图 8

图 9

  • 全选原理图 CTRL + A ,使用编辑菜单:编辑 - 对齐 - 对齐网格功能。检查断开或者不对的地方修正。

图 10

  • 另存 ASCII 再导入

已知问题

  • 立创EDA目前不支持Alitum的PCB规则导入,所以导入后的PCB文件规则相关参数需要自行调整,目前铺铜间隙默认设置为10mil。

  • Altium文件的内电层导入后需要手动调整。

  • 暂时不支持AD的IEEE符号导入,如下:

  • 请不要反复将你的原理图或PCB导出AD格式后又导入,这个操作可能会导致细节丢失!!!

  • 导入Altium文件时,如果有不支持的字符将自动转为下滑线,所以导入后可能会发现有网络标签、器件名称、封装名多了一个下划线,请手动修改。

  • 如果Altium文件非常大,导入时间将会非常长,建议先删除铺铜再导入。

  • 导入 AD 文件的边框处理逻辑:keep-out 转为边框层, board shape 转为文档层,mechanical 等转为机械层

  • 导入的 AD 文件最大支持 100MB,文件越大会导致导入时间越长或导入失败,建议手动减小文件体积

Eagle 原理图/PCB/库文件

请看一下章节

KiCAD 原理图/PCB/库文件

请看下下个章节

LTspice原理图文件

因立创EDA重写了文件导入的转换代码,LTspice文件的导入需要重新开发,暂时还没有对其进行开发,暂未支持导入。


goToTop